[BUG] Package not working for python < 3.8
Closedopened 5 months ago by jazzbah · 4 comments
Reference in New Issue
There is no content yet.
Delete Branch '%!s(<nil>)'
Deleting a branch is permanent. It CANNOT be undone. Continue?
Describe the bug
The latest version (1.0.7) can't be used on an environment with python < 3.8 due to an import error.
python -m pip install py3-validate-email
My debug output
The script runs on python 3.6 & python 3.7
Please complete the following information:
py3-validate-emailmodule version: 1.0.7
Damn, thanks for the report.
Is there a way for you to use a newer python version? I'd like to keep the
Literalimport and bump the minimum required version for python.
If not, I need to remove the import (or make it optional).
Another option would be to require typing_extensions for this project, which is kinda an overreach: https://pypi.org/project/typing-extensions/
For now we are using version 1.0.5, which does not have this import yet, thus works, but we won't be able to upgrade then...
We will upgrade to python >= 3.8 eventually, but not posible short term.
py3-validate-email 1.0.8 is now available at your convenience.
Please consider upgrading your python version ASAP, since I plan to deprecate older python versions over time, as I can't guarantee keeping them supported in the future.